Win10, PySide2/QWebEngineView and PyInstaller

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Win10, PySide2/QWebEngineView and PyInstaller

ijbrewster
As a follow-up to below, I have noticed that if I do something like set the background color of the QWebEngineView when creating it, I *do* get a flash of that color - just not the HTML content, and it goes away quite quickly. So apparently the QWebEngineView does load, but as soon as it tries to process content, it crashes? I would think that should generate some sort of output, however, but it doesn't.

Thoughts?

---
Israel Brewster
Software Engineer
Alaska Volcano Observatory 
Geophysical Institute - UAF 
2156 Koyukuk Drive 
Fairbanks AK 99775-7320
Work: 907-474-5172
cell: 907-328-9145

On Apr 18, 2019, at 10:59 AM, Israel Brewster wrote:
I’m having problems getting PySide2/QWebEngineView to work on windows with PyInstaller. In short, even when just doing a very basic “Hello world” page via setHTML, nothing is ever displayed. Of course the app works properly when not run via PyInstaller.
Details:
- As per the instructions at https://github.com/pyinstaller/pyinstaller/wiki/How-to-Report-Bugs#make-sure-everything-is-packaged-correctly, I am running pyinstaller in the —onesie mode, with the latest development version, from a command window, without UPX, and in debug mode
- no errors of any sort are generated when running
- I have a custom hook set up to collect data files for shiboken2 and PySide2:
from PyInstaller.utils.hooks import collect_data_files
datas = collect_data_files('shiboken2', include_py_files=True, subdir='support')
datas += collect_data_files('PySide2', include_py_files=True, subdir='support’)
- I set the “QTWEBENGINEPROCESS_PATH” environment variable to point to the QtWebEngineProcess.exe, thus eliminating that error
- I made sure my .spec file included the translations and resources directories in the proper location, thus eliminating those errors
So at this point, I have cleaned up all the errors that are reported, but still don’t get any display in the QWebEngineView, even for the most basic of pages. Where can I look next? Output when running is below.
$ ./dist/SO2\ Explorer/SO2\ Explorer.exe
[160] PyInstaller Bootloader 3.x
[160] LOADER: executable is C:\Users\Israel\Development-Win\tropomi_gui\dist\SO2 Explorer\SO2 Explorer.exe
[160] LOADER: homepath is C:\Users\Israel\Development-Win\tropomi_gui\dist\SO2 Explorer
[160] LOADER: _MEIPASS2 is NULL
[160] LOADER: archivename is C:\Users\Israel\Development-Win\tropomi_gui\dist\SO2 Explorer\SO2 Explorer.exe
[160] LOADER: No need to extract files to run; setting extractionpath to homepath
[160] LOADER: SetDllDirectory(C:\Users\Israel\Development-Win\tropomi_gui\dist\SO2 Explorer)
[160] LOADER: Already in the child - running user's code.
[160] LOADER: Python library: C:\Users\Israel\Development-Win\tropomi_gui\dist\SO2 Explorer\python37.dll
[160] LOADER: Loaded functions from Python library.
[160] LOADER: Manipulating environment (sys.path, sys.prefix)
[160] LOADER: sys.prefix is C:\Users\Israel\Development-Win\tropomi_gui\dist\SO2 Explorer
[160] LOADER: Pre-init sys.path is C:\Users\Israel\Development-Win\tropomi_gui\dist\SO2 Explorer\base_library.zip;C:\Users\Israel\Development-Win\tropomi_gui\dist\SO2 Explorer
[160] LOADER: Setting runtime options
[160] LOADER: Initializing python
[160] LOADER: Overriding Python's sys.path
[160] LOADER: Post-init sys.path is C:\Users\Israel\Development-Win\tropomi_gui\dist\SO2 Explorer\base_library.zip;C:\Users\Israel\Development-Win\tropomi_gui\dist\SO2 Explorer
[160] LOADER: Setting sys.argv
[160] LOADER: setting sys._MEIPASS
[160] LOADER: importing modules from CArchive
[160] LOADER: extracted struct
[160] LOADER: callfunction returned...
[160] LOADER: extracted pyimod01_os_path
[160] LOADER: callfunction returned...
[160] LOADER: extracted pyimod02_archive
[160] LOADER: callfunction returned...
[160] LOADER: extracted pyimod03_importers
[160] LOADER: callfunction returned...
[160] LOADER: Installing PYZ archive with Python modules.
[160] LOADER: PYZ archive: PYZ-00.pyz
[160] LOADER: Running pyiboot01_bootstrap.py
[160] LOADER: Running runtimehook-harp.py
[160] LOADER: Running pyi_rth_qt5plugins.py
[160] LOADER: Running pyi_rth_pkgres.py
[160] LOADER: Running pyi_rth_win32comgenpy.py
[160] LOADER: Running pyi_rth_multiprocessing.py
[160] LOADER: Running pyi_rth_qt5webengine.py
[160] LOADER: Running SO2 Explorer.py
---
Israel Brewster
Software Engineer
Alaska Volcano Observatory 
Geophysical Institute - UAF 
2156 Koyukuk Drive 
Fairbanks AK 99775-7320
Work: 907-474-5172
cell: 907-328-9145


--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/pyinstaller.
For more options, visit https://groups.google.com/d/optout.