Stupid PyQt5 problem

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Stupid PyQt5 problem

davecortesi
Been a while since I needed to use PyInstaller, and now that I do, I am running into what must be a user error, but I can't figure it out.

Python 3.5

MacOS 10.10

PyInstaller 3.2

Python imports and runs PyQt5 modules fine.

DYLD_LIBRARY_PATH includes /Developer/Qt5.6/5.6/clang_64/lib/ which is the location of all the Qt frameworks. But just to be sure, I also added a "-p /Developer/Qt5.6/5.6/clang_64/lib/" to the PyInstaller command.

So the command is

pyinstaller -y --clean --log-level ERROR --noupx --noconsole --onefile -p /Developer/Qt5.6/5.6/clang_64/lib myscript.py

and no Qt modules are found, all yield errors like:

2908 ERROR: Can not find path ./QtCore.framework/Versions/5/QtCore (needed by /Library/Frameworks/Python.framework/Versions/3.5/lib/python3.5/site-packages/PyQt5/Qt/plugins/imageformats/libqjpeg.dylib)

and the built app does not run of course.

So, what obvious thing am I missing here?

Thanks for any help.


--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/pyinstaller.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

AW: [PyInstaller] Stupid PyQt5 problem

Niemann, Hartmut

Hello David!

 

You could give pyinstaller 3.1 or 3.0 a try.

The other day I had an application that could be built just fine with 3.0 and 3.1 and gave errors with pyinstaller 3.2.

(Maybe I can find the time to investigate further.)

 

Mit freundlichen Grüßen
Dr. Hartmut Niemann

Siemens AG
MO MLT LM EN CCI 1
Werner-von-Siemens-Str. 67
91052 Erlangen, Deutschland
Mobil: +49 173 5342327
[hidden email]
www.siemens.com/ingenuityforlife
www.siemens.com/ingenuityforlife

Von: [hidden email] [mailto:[hidden email]] Im Auftrag von David Cortesi
Gesendet: Montag, 14. November 2016 19:14
An: [hidden email]
Betreff: [PyInstaller] Stupid PyQt5 problem

 

Been a while since I needed to use PyInstaller, and now that I do, I am running into what must be a user error, but I can't figure it out.

Python 3.5

MacOS 10.10

PyInstaller 3.2

Python imports and runs PyQt5 modules fine.

DYLD_LIBRARY_PATH includes /Developer/Qt5.6/5.6/clang_64/lib/ which is the location of all the Qt frameworks. But just to be sure, I also added a "-p /Developer/Qt5.6/5.6/clang_64/lib/" to the PyInstaller command.

So the command is

pyinstaller -y --clean --log-level ERROR --noupx --noconsole --onefile -p /Developer/Qt5.6/5.6/clang_64/lib myscript.py

and no Qt modules are found, all yield errors like:

2908 ERROR: Can not find path ./QtCore.framework/Versions/5/QtCore (needed by /Library/Frameworks/Python.framework/Versions/3.5/lib/python3.5/site-packages/PyQt5/Qt/plugins/imageformats/libqjpeg.dylib)

and the built app does not run of course.

So, what obvious thing am I missing here?

Thanks for any help.

 

--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/pyinstaller.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/pyinstaller.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Stupid PyQt5 problem

davecortesi
Fixed the problem by installing the current dev tip. (Just like we tell the other people.) No other change; and it ran.

--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/pyinstaller.
For more options, visit https://groups.google.com/d/optout.
Loading...