Pyinstaller not able to run datacompy library

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Pyinstaller not able to run datacompy library

souvik chattopadhyay
Hi
I am using datacompy to compare 2 dataframes. I wanted to make this an exe using pyinstaller but its failing to support datacompy.
What could be the reason and how to resolve it?

--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/pyinstaller/50ee2ced-51c7-4b85-b29d-d46fb8832d8eo%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Pyinstaller not able to run datacompy library

bwoodsend

Hi,

datacompy has some data files in it which PyInstaller doesn’t spot. I’m assuming you get some kind of FileNotFoundError when you run it? In which case you have to tell PyInstaller to include them. I’ve put together a hook you can use. Put it in your current working dir and either pass the argument --additional-hooks-dir . or add '.' to the hookspath=[] list in the spec file.

Pandas is usually a pain to PyInstaller. If you don’t know already - you probably will need to tell PyInstaller not to try and include matplotlib, PyQt, PyQt5, scipy etc. unless you are actually using them.

Brénainn

--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/pyinstaller/a55b4f47-0e62-42e6-9650-580eb74ede97o%40googlegroups.com.