PySide 1.1.x works with PyInstaller on Mac OS X and Windows

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Zak
Reply | Threaded
Open this post in threaded view
|

PySide 1.1.x works with PyInstaller on Mac OS X and Windows

Zak
Hello PyInstaller Folks,

I think PySide should be added to the list of supported packages on the
PyInstaller website. PySide is quite similar to PyQt, but I prefer
PySide because it has a more permissive license and it uses the more
sensible API by default. PySide also produces smaller binaries.

The following combinations all work with PyInstaller:

1. Mac OS X 10.7
Python 2.7.2 64-bit
PySide 1.1.1

2. Mac OS X 10.8
Python 2.7.3 64-bit
PySide 1.1.1

3. Windows 7 64-bit
Python 2.7.3 32-bit
PySide 1.1.2

4. Windows 8 32-bit
Python 2.7.3
PySide 1.1.2

The one-file executables I built were always completely portable between
different versions of the same OS. I can build on OS X 10.8 and run on
10.7 and vice versa, same goes for Windows 7 and 8. Apparently my
executable even works on Windows XP.

Good luck,

Zak Fallows

--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at http://groups.google.com/group/pyinstaller?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.


Reply | Threaded
Open this post in threaded view
|

Re: PySide 1.1.x works with PyInstaller on Mac OS X and Windows

Martin Zibricky
Zak píše v So 06. 04. 2013 v 18:23 -0400:
> Hello PyInstaller Folks,
>
> I think PySide should be added to the list of supported packages on
> the
> PyInstaller website. PySide is quite similar to PyQt,

Does pyinstaller handle qt plugins with PySide?
What advanced features from PySide do you use in your app?

--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at http://groups.google.com/group/pyinstaller?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.


Zak
Reply | Threaded
Open this post in threaded view
|

Re: PySide 1.1.x works with PyInstaller on Mac OS X and Windows

Zak
I don't think I used any advanced features or plugins. I have used a
number of Qt features though - QWebView for embedding a web browser,
QPrinter to use office printers, and USB peripherals.

In short, PySide and PyQt both "just work" with Mac OS X and Windows
when packaged by PyInstaller. I have not tested either of them on Linux
yet, but I hope to do that.

Good luck,

Zak Fallows

On 4/7/13 5:52 AM, Martin Zibricky wrote:
> Zak píše v So 06. 04. 2013 v 18:23 -0400:
>> Hello PyInstaller Folks,
>>
>> I think PySide should be added to the list of supported packages on
>> the
>> PyInstaller website. PySide is quite similar to PyQt,
> Does pyinstaller handle qt plugins with PySide?
> What advanced features from PySide do you use in your app?
>

--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at http://groups.google.com/group/pyinstaller?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.