[MacOS10.15.4, Python3.8] Execution failed: [Errno 2] No such file or directory: 'arch'

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[MacOS10.15.4, Python3.8] Execution failed: [Errno 2] No such file or directory: 'arch'

Joseph Liang
Hello:

I have a python script 'PlotGui.py' that uses packages tkinter, matplotlib, among others.

Whether I execute pyinstaller with the command 'pyinstaller --onefile -w Plot_Gui.py', or simply 'pyinstaller Plot_Gui.py', I keep running into this error. (picture attached). I've tried on PyInstaller 3.6, and downgraded to 3.4, but still get this problem.

Any clue how to fix this?

Thanks,


--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/pyinstaller/0622990f-ef15-4199-8358-eb9bfbfdd6bb%40googlegroups.com.

Screen Shot 2020-05-15 at 4.15.09 PM.png (563K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [MacOS10.15.4, Python3.8] Execution failed: [Errno 2] No such file or directory: 'arch'

Brendan Simon (eTRIX)
Have you got xcode command line tools installed on your Mac ?

If not, then install with:

$ xcode-select --install

Google with throw up lots of hits.  Here's one.

https://osxdaily.com/2014/02/12/install-command-line-tools-mac-os-x/

--

$ arch
i386

$ which arch
/usr/bin/arch

Brendan

--


On 16/5/20 9:15 am, Joseph Liang wrote:
Hello:

I have a python script 'PlotGui.py' that uses packages tkinter, matplotlib, among others.

Whether I execute pyinstaller with the command 'pyinstaller --onefile -w Plot_Gui.py', or simply 'pyinstaller Plot_Gui.py', I keep running into this error. (picture attached). I've tried on PyInstaller 3.6, and downgraded to 3.4, but still get this problem.

Any clue how to fix this?

Thanks,


--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/pyinstaller/0622990f-ef15-4199-8358-eb9bfbfdd6bb%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/pyinstaller/29c33289-e4b6-86df-cccf-c75cb338c43e%40etrix.com.au.
Reply | Threaded
Open this post in threaded view
|

Re: [MacOS10.15.4, Python3.8] Execution failed: [Errno 2] No such file or directory: 'arch'

Joseph Liang
Managed to realize that my PATH was totally messed up - after resetting it I do not have that error anymore! However, app is still not working.... Will write about errors in another post, as it is no longer related to the arch problem.

Thanks!

On Monday, May 18, 2020 at 12:52:58 AM UTC-7, Brendan Simon (eTRIX) wrote:
Have you got xcode command line tools installed on your Mac ?

If not, then install with:

$ xcode-select --install

Google with throw up lots of hits.  Here's one.

<a href="https://osxdaily.com/2014/02/12/install-command-line-tools-mac-os-x/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fosxdaily.com%2F2014%2F02%2F12%2Finstall-command-line-tools-mac-os-x%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFkKzlKpXhUjdWAP5zUdaMGXMqrmw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fosxdaily.com%2F2014%2F02%2F12%2Finstall-command-line-tools-mac-os-x%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFkKzlKpXhUjdWAP5zUdaMGXMqrmw&#39;;return true;">https://osxdaily.com/2014/02/12/install-command-line-tools-mac-os-x/

--

$ arch
i386

$ which arch
/usr/bin/arch

Brendan

--


On 16/5/20 9:15 am, Joseph Liang wrote:
Hello:

I have a python script 'PlotGui.py' that uses packages tkinter, matplotlib, among others.

Whether I execute pyinstaller with the command 'pyinstaller --onefile -w Plot_Gui.py', or simply 'pyinstaller Plot_Gui.py', I keep running into this error. (picture attached). I've tried on PyInstaller 3.6, and downgraded to 3.4, but still get this problem.

Any clue how to fix this?

Thanks,


--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="SdQKSZF_AQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">pyins...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/pyinstaller/0622990f-ef15-4199-8358-eb9bfbfdd6bb%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/pyinstaller/0622990f-ef15-4199-8358-eb9bfbfdd6bb%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/pyinstaller/0622990f-ef15-4199-8358-eb9bfbfdd6bb%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/pyinstaller/0622990f-ef15-4199-8358-eb9bfbfdd6bb%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/pyinstaller/37d9c1d0-e2db-4d6d-b7f8-93532d4e44e0%40googlegroups.com.