Help needed: Error loading Python lib

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Help needed: Error loading Python lib

Adwaya Gupta
When I run the executable on my Mac OSX, I get an error message in terminal saying:

[6845] Error loading Python lib '/Users/adwaya/Documents/Loginfunds/exe/dist/LoginAndFunds/Python': dlopen: dlopen(/Users/adwaya/Documents/Loginfunds/exe/dist/LoginFunds/Python, 10): no suitable image found.  Did find:

/Users/adwaya/Documents/Loginfunds/exe/dist/LoginFunds/Python: code signature invalid for '/Users/adwaya/Documents/Loginfunds/exe/dist/LoginFunds/Python'


logout

Saving session...

...copying shared history...

...saving history...truncating history files...

...completed.


I am using python 3.8 which is the latest version at time of writing however I did install pyinstaller 4.0.dev0 using pip3 so I'm not sure if that has anything to do with it.


--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/pyinstaller/023af845-798a-4ef2-80a1-406d4529baac%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Help needed: Error loading Python lib

bwoodsend

PyInstaller doesn’t support Python 3.8.It’s probably just that. Grab a vanilla Python 3.7 for PyInstaller-ing.

--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/pyinstaller/f610230e-b9be-4594-94bd-d5fff6b2c9aeo%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Help needed: Error loading Python lib

jim kaubisch
It also doesn't seem to support 3.7 beyond 3.7.6 for me

What built/ ran fine for 3.7.6 falls over with the same "code signature invalid" error for 3.7.7 and 3.7.8

Am needing to ,migrate to 3.8. Any idea when PyInstaller will support 3.8 (and 3.7.7 and 3.7.8) ?


On Thursday, June 11, 2020 at 7:21:53 AM UTC-7, bwoodsend wrote:

PyInstaller doesn’t support Python <a href="http://3.8.It" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F3.8.It\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNELWjoZfxZav6XKfku_ZtR6cIdfdg&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F3.8.It\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNELWjoZfxZav6XKfku_ZtR6cIdfdg&#39;;return true;">3.8.It’s probably just that. Grab a vanilla <a href="https://www.python.org/downloads/release/python-377/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.python.org%2Fdownloads%2Frelease%2Fpython-377%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHnZNkeU83Zev85XtToOyY7hp0Iog&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.python.org%2Fdownloads%2Frelease%2Fpython-377%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHnZNkeU83Zev85XtToOyY7hp0Iog&#39;;return true;">Python 3.7 for PyInstaller-ing.

--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/pyinstaller/8068e21f-51c7-4da8-891c-5f598be02f6do%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Help needed: Error loading Python lib

jim kaubisch
In reply to this post by bwoodsend
Doesn't seem to support 3.7 beyond 3.7.6 for me.
Things that used to run fine built against 3.7.6 are now falling over when built against 3.7.7 and 3.7.8 with the same "code signature invalid" error

3.7 is close to retirement it seems. What is the status of 3.8 support? 

Thanks

On Thursday, June 11, 2020 at 7:21:53 AM UTC-7, bwoodsend wrote:

PyInstaller doesn’t support Python <a href="http://3.8.It" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F3.8.It\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNELWjoZfxZav6XKfku_ZtR6cIdfdg&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2F3.8.It\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNELWjoZfxZav6XKfku_ZtR6cIdfdg&#39;;return true;">3.8.It’s probably just that. Grab a vanilla <a href="https://www.google.com/url?q=https%3A%2F%2Fwww.python.org%2Fdownloads%2Frelease%2Fpython-377%2F&amp;sa=D&amp;sntz=1&amp;usg=AFQjCNHnZNkeU83Zev85XtToOyY7hp0Iog" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.python.org%2Fdownloads%2Frelease%2Fpython-377%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHnZNkeU83Zev85XtToOyY7hp0Iog&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.python.org%2Fdownloads%2Frelease%2Fpython-377%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHnZNkeU83Zev85XtToOyY7hp0Iog&#39;;return true;">Python 3.7 for PyInstaller-ing.Doesn't seem to support 3.7 beyond 3.7.6.

--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/pyinstaller/37cea0f0-6cba-49e2-8a7b-8ad0660d80c1o%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Help needed: Error loading Python lib

bwoodsend

Well if it’s happening on any of the 3.7s then it’s definitely not the 3.8 compatibility issue. 3.7 will certainly not be retiring soon - you should still be able to use anything from 3.5 to 3.7.7. In that case can you give us some more information on what you’re doing.

  • Full build and run trackbacks - not the last line.
  • What packages your using and their versions.

--
You received this message because you are subscribed to the Google Groups "PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/pyinstaller/33d16d15-c7eb-4f92-87df-b8aba5cc2db9n%40googlegroups.com.